Damn you, IE5 for the

Damn you, IE5 for the Mac!! Damn you!! I have all this cool stuff I want to do that works in IE 5 for the PC, and Mozilla for everything – and you’re the only one left who doesn’t work, but all those Mac People use you! What’s WRONG with you? Can’t you get updated or something? Is that too much to ask?

Leave a Reply